SPD-SX Trigger Inputs not working...

GrimmReefer

Senior Member
Howdy fellow drummers! Just throwing this out in hopes someone has had a similar issue with an easy fix.

My SPD-SX which I used heavily works great but recently my trigger inputs have stopped working. I typically use a BT-1 as an external trigger. My assumption is a soldering issue at the input jack but I have never opened the unit up before. The main issue is the repair shop is 6 weeks backed up and with gigs booked its hard to part with my sampler for that amount of time.

Has anyone had this issue and repaired it themselves? Thanks in advance for any advice!
 

electrodrummer

Senior Member
This happens to all of these units - the power / audio / trigger inputs come away from the board.

(do them ALL whilst you're in there).

Any electronic engineer can do this for you. Don't have a go if you've never soldered.
 

GrimmReefer

Senior Member
Thank you!

Any suggestions for finding a good electronic engineer? Google is not helping with that. I just want to be sure they are familiar with Roland products.
 

electrodrummer

Senior Member
Thank you!

Any suggestions for finding a good electronic engineer? Google is not helping with that. I just want to be sure they are familiar with Roland products.

Well, it's huge planet out here. I know someone in London....

Doesn't really matter if they know Roland products it's just re-soldering some jack sockets - can't get more basic than that :)

Maybe post on the vdrums.com site or one of the many Facebook edrum groups[1] and say you're looking for recommendations in your country/location.

[1]
https://www.facebook.com/groups/300497260045442 or
https://www.facebook.com/groups/601890056510298 etc
 
Top