Cleaning black marks off of a DW collector's series aluminium snare?

Jasperdrummer

Junior Member
I've been scratching my head over how I can remove these black markings from my snare. Absolutely no idea how they got there either. I've tried wiping it down with a soft cloth using Windex + water. Also the water + vinegar solution. Nothing seems to be helping. I was thinking at one point that it was part of how it was crafted but...I don't think so.
Any help would be appreciated.
87293
 

SYMBOLIC DEATH

Senior Member
Contact DW and see if this is a common issue with their aluminium shells. Do they feel like something is stuck on there? Is it also on the outside of the shell? I'm wondering if it's from a Remo reverse black dot that detached from the head. Remo had an issue with their dots detaching back in the early 2000's.
 

Steady Freddy

Pioneer Member
I have two of those and that's not normal. Those cast shells are coated and I would guess those black specs got on the shell while the coating was still wet, Send an e mail to DW and see what they say.
 

Jasperdrummer

Junior Member
I have two of those and that's not normal. Those cast shells are coated and I would guess those black specs got on the shell while the coating was still wet, Send an e mail to DW and see what they say.
So, as strange as this sounds I managed to remove pretty much all of the specs with my fingernails alone. It honestly looks like wet paint but I'm guessing that it could of been from when I had an Evans head on their and the black logo had just worn off & into the drum itself. I had a friend that instead of playing centred on the snare, he'd buzz roll quite a bit up where the logo was. Personally, I don't find it normal how the coating could just ware off & find itself inside the shell though.
 

Jasperdrummer

Junior Member
Contact DW and see if this is a common issue with their aluminium shells. Do they feel like something is stuck on there? Is it also on the outside of the shell? I'm wondering if it's from a Remo reverse black dot that detached from the head. Remo had an issue with their dots detaching back in the early 2000's.
I'll keep you updated on the issue. Read my post above..could be the problem. I think to a degree the shell is possibly warped. Hence why the markings are getting inside of the shell. The one time I remember it potentially being damaged was when I had my kit set up in the living area & my sister knocked the snare over. It landed on carpet, but the lugs could of seen some damage. Still in locked into the stand.

I currently do use a dotted head on there. Pretty sure it's a Remo Powerstroke P3. I don't like the head personally. The dot is grey however.

I will contact DW though. Thanks guys.
 
Last edited:
Top