Alesis DM10X - EZDrummer MIDI setup. (ASIO)

Carbon

Junior Member
So i bought my kit seccond hand and I've had it for around 6 months.

I hooked it into my PC via USB and it instantly started regerstering as a midi device.

However the delay was awful so I downloaded asio4all and put a 128 buffer at 3.6 ms delay but the quality is still not great and I'm reluctant to go over 4ms. I have a gigabyte 970a g46 mobo and a pair of DT 770 pros. Also I cant play my music through Spotify or edge as it's being used by ASIO.

As well as this some of the cymbals are really quiet and the bass drum double hits for some reason.
 

KamaK

Platinum Member
With that particular Mobo, I believe there are 12 USB 2.0 ports and 2 USB 3.0 ports (on the back panel).

Is here any difference in latency when you switch the drums between the two port types?

Do you have anything else plugged into the same motherboard-USB HUB as the drum kit (flash drive, mouse, wireless, etc)?
 

Carbon

Junior Member
With that particular Mobo, I believe there are 12 USB 2.0 ports and 2 USB 3.0 ports (on the back panel).

Is here any difference in latency when you switch the drums between the two port types?

Do you have anything else plugged into the same motherboard-USB HUB as the drum kit (flash drive, mouse, wireless, etc)?
Thanks for your response. I have my perpherals plugged into the USB 2 hubs and my k70 plugged into USB 3. I have tried the USB 2 & 3 ports and it didn't make much difference. I just tried my pcie USB 3 expansion and that didn't work either. The delay isn't a big problem though it's more the audio quality when using ASIO and the fact that I can't use backing music.

Thanks
 

Carbon

Junior Member
http://imgur.com/a/PjO7E

This is what i currently have and it works! Almost...

The audio cuts out eery 30 seconds or so for around 2 secs :(
And also quality isnt amazing but i guess that not the end of the world i am playing a yt mp3 atm :)
 
Top