DRUMMERWORLD OFFICIAL DISCUSSION FORUM   

Go Back   DRUMMERWORLD OFFICIAL DISCUSSION FORUM > Drum Gear > Pedals

Pedals Discuss Pedals

Reply
 
Thread Tools
  #1  
Old 06-16-2011, 02:25 AM
cfspawn cfspawn is offline
Junior Member
 
Join Date: Jun 2011
Location: Hobart Tasmania Australia
Posts: 1
Default No return or feel in Eliminator Demon Drive pedals.

Hi All, I'm having issues with my Demon drive main pedal. it seems to have no feel or return like it used too. I'm quite new to these pedals and unsure of the best way to adjust them. Also I'm wondering if the springs get stretched and need replacing?

Any help would be appreciated.

Cheers.
Reply With Quote
  #2  
Old 06-16-2011, 10:39 AM
uniin's Avatar
uniin uniin is offline
Gold Member
 
Join Date: Sep 2010
Location: Blue Mountains, Australia
Posts: 1,216
Default Re: No return or feel in Eliminator Demon Drive pedals.

Quote:
Originally Posted by cfspawn View Post
Also I'm wondering if the springs get stretched and need replacing? .
that happens if you have max tension.... but doesn't happen quickly. say after 6~12months ++
Reply With Quote
  #3  
Old 06-16-2011, 03:04 PM
joeysnare's Avatar
joeysnare joeysnare is offline
Silver Member
 
Join Date: Mar 2006
Location: saskatchewan
Posts: 702
Default Re: No return or feel in Eliminator Demon Drive pedals.

id be checking either the clamp that connects the foot board to the main drive shaft, or the spring mounts that are also connected to the drive shaft, they could be slipping and in need of some tightening.
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is On
HTML code is Off




All times are GMT +2. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Bernhard Castiglioni's DRUMMERWORLD.com