DRUMMERWORLD OFFICIAL DISCUSSION FORUM   

Go Back   DRUMMERWORLD OFFICIAL DISCUSSION FORUM > Drum Gear > Electronic Drums

Electronic Drums All about Electronic Drums

Reply
 
Thread Tools
  #1  
Old 06-01-2011, 07:04 PM
BackbeatJoe BackbeatJoe is offline
Junior Member
 
Join Date: Mar 2007
Location: Manville, New Jersey
Posts: 11
Default Problem with Roland SPD-S. Any insight?

I recently purchased a pre-owned Roland SPD-S. I have just now put it into use for a project I'm working on. Unfortunately, along with the sounds, I am hearing mechanical white noise the entire time it is on. It sounds like a high pitch hum, or like a "whirring" sound and it's constant. Also, I hear different mechanical noises at different pitches as I press various buttons and select different functions. The sound is audible when both the headphones are directly in, and when the output R & L channels are being used. All the functions and triggering are in perfect order, but this sound won't go away.

Has anyone heard of this? Is there a solution? Or was I sold an instrument with a foot in the grave?

Thanks in advance for any info you might have.
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is On
HTML code is Off




All times are GMT +2. The time now is 07:14 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Bernhard Castiglioni's DRUMMERWORLD.com