DRUMMERWORLD OFFICIAL DISCUSSION FORUM   

Go Back   DRUMMERWORLD OFFICIAL DISCUSSION FORUM > Drum Gear > Other Gear

Other Gear Discuss Hardware and all other equipment not covered in the other topics

Reply
 
Thread Tools
  #1  
Old 07-12-2008, 12:36 AM
Kaiser Kaiser is offline
Member
 
Join Date: Jul 2008
Location: Ireland
Posts: 60
Default Sonor Hi-Hat problem

Hi
I have a Sonor 400 Hi-Hat stand that hasnt worked properly since I loaned it out to a guy last week. Basically, when I lift my foot off the pedal, there is no 'damping' of the rod so it makes a loud sound when the hi-hat pedal is fully released. I think there may be a part missing. Should there be an extra nut between the hi-hat rod and the lower rod that you screw it into? Its doing my head in! Thanks in advance.
Reply With Quote
  #2  
Old 07-21-2008, 05:49 AM
Beaton29's Avatar
Beaton29 Beaton29 is offline
Junior Member
 
Join Date: Apr 2007
Location: Nova Scotia
Posts: 2
Default Re: Sonor Hi-Hat problem

I've had problems with the same stand recently. The rod that supports the cymbal screws into the rod which connects to the pedal. These rods come loose and you can't close the hats. Take the top pipe out the stand, screw the rods together. They will sooner or later come loose again. I bought a bottle of Locktite screw tightener (buy the temporary not the the permanant) at a hardware store for 7$, hasn't came loose since (a few jams and a show)

I'm loving my new sonor kit, the hardware with it is fantastic minus the rods in the hats
__________________
You know the drum was the first instrument besides the human voice. -Billy Higgins
Reply With Quote
  #3  
Old 07-23-2008, 07:45 AM
LM201's Avatar
LM201 LM201 is offline
Senior Member
 
Join Date: Apr 2008
Location: Mt, Juliet, Tennessee
Posts: 429
Default Re: Sonor Hi-Hat problem

That glue they use in pipe joints, if you're real desperate
__________________
PEWFLADCC-Master Cake Baker
!!!!RIP FINN!!!!
Reply With Quote
  #4  
Old 07-25-2008, 02:48 PM
Kaiser Kaiser is offline
Member
 
Join Date: Jul 2008
Location: Ireland
Posts: 60
Default Re: Sonor Hi-Hat problem

Thanks for the help guys, I'll try that!
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is On
HTML code is Off




All times are GMT +2. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Bernhard Castiglioni's DRUMMERWORLD.com