DRUMMERWORLD OFFICIAL DISCUSSION FORUM

DRUMMERWORLD OFFICIAL DISCUSSION FORUM (http://www.drummerworld.com/forums/index.php)
-   Pedals (http://www.drummerworld.com/forums/forumdisplay.php?f=27)
-   -   Has anyone had this problem with a double pedal link? (http://www.drummerworld.com/forums/showthread.php?t=109319)

Trilogy72 08-08-2013 03:16 PM

Has anyone had this problem with a double pedal link?
 
I recently noticed a clicking sound coming from the left side u-joint from my Mapex Falcon pedal link. I have checked the bolts and made sure nothing was loose.
I posted a video of this on YouTube to better explain the problem. Just wanted to get some feedback to see if any of you guys have had this problem.

Video Link: http://youtu.be/LSRLNBEsfQI

Dre25 08-08-2013 03:21 PM

Re: Has anyone had this problem with a double pedal link?
 
It's a replacement one too isn't it?

My falcon was clicking but eventually I realised it was the spike used to dig into the carpet unscrewing itself (and rising up) from vibrations. The idiots put it right under the footboard lol

Trilogy72 08-08-2013 03:32 PM

Re: Has anyone had this problem with a double pedal link?
 
Quote:

Originally Posted by Dre25 (Post 1168796)
It's a replacement one too isn't it?

My falcon was clicking but eventually I realised it was the spike used to dig into the carpet unscrewing itself (and rising up) from vibrations. The idiots put it right under the footboard lol

Yes, this is the replacement pedal. The pedal itself is great and I have had no problems with it at all. The link on the new and the old pedal are the same so this is not a problem with the new design.

BigDinSD 08-08-2013 04:03 PM

Re: Has anyone had this problem with a double pedal link?
 
Can you peel back or remove the rubber cover? Sounds like the U joint is loose. Plus, there are only 3 pieces in that assembly.

On double pedals, that is usually the weakest link and goes out first. I don't have a Mapex, but that can be a common prob for us double pedallers.

Trilogy72 08-08-2013 04:12 PM

Re: Has anyone had this problem with a double pedal link?
 
Quote:

Originally Posted by BigDinSD (Post 1168805)
Can you peel back or remove the rubber cover? Sounds like the U joint is loose. Plus, there are only 3 pieces in that assembly.

On double pedals, that is usually the weakest link and goes out first. I don't have a Mapex, but that can be a common prob for us double pedallers.

The rubber cover is glued and will not let me move it. It's still under warranty so I will not break the seal at this point to look inside. I contacted Mapex today about this and I am waiting for a response.

brentcn 08-08-2013 04:20 PM

Re: Has anyone had this problem with a double pedal link?
 
Quote:

Originally Posted by Trilogy72 (Post 1168808)
The rubber cover is glued and will not let me move it. It's still under warranty so I will not break the seal at this point to look inside. I contacted Mapex today about this and I am waiting for a response.

Currently, only Axis and the new Atlas/Ludwig pedals have decent U-joints. Weak U-joints are also the reason the slave pedal feels sluggish.

BigDinSD 08-08-2013 04:54 PM

Re: Has anyone had this problem with a double pedal link?
 
Quote:

Originally Posted by brentcn (Post 1168810)
Currently, only Axis and the new Atlas/Ludwig pedals have decent U-joints. Weak U-joints are also the reason the slave pedal feels sluggish.

Trick pedals just recently came out with a replacement U Joint axle. I know they have one for the DW's and also a universal one. Something to keep in mind later.

I have a Trick double pedal, and their U joints are just so insanely smooth and well built. No Play at all.

http://www.shoptrick.com/categories/...Shafts-74.html

Reggae_Mangle 08-08-2013 08:52 PM

Re: Has anyone had this problem with a double pedal link?
 
+1 on the Trick U-joint. Minimal lag between slave and master pedal, but having switched to two singles, I can definitely say that minimal just means better than most other pedals. Having the ability to covert the pedal into a double is a God-send though. Not a lot of gigs here where the option of a second bass drum is made available.

Trilogy72 08-08-2013 11:03 PM

Re: Has anyone had this problem with a double pedal link?
 
I just got a response from Mapex and they are shipping me a new link. There customer service is amazing and very quick to respond.

Reggae_Mangle 08-09-2013 10:02 AM

Re: Has anyone had this problem with a double pedal link?
 
Cool! Glad to hear it's being sorted out!


All times are GMT +2. The time now is 07:01 PM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Bernhard Castiglioni's DRUMMERWORLD.com