DRUMMERWORLD OFFICIAL DISCUSSION FORUM

DRUMMERWORLD OFFICIAL DISCUSSION FORUM (http://www.drummerworld.com/forums/index.php)
-   Pedals (http://www.drummerworld.com/forums/forumdisplay.php?f=27)
-   -   Tama Speed Cobra problem? (http://www.drummerworld.com/forums/showthread.php?t=107179)

Matteo 05-24-2013 02:09 AM

Tama Speed Cobra problem?
 
I have a Speed Cobra double pedal and while I really like them, I've been having trouble as of late. Here is a video showing the problem:

Speed Cobra problem

Can you see how sluggish the slave pedal is? I've tried everything I can think of to fix it but am out of ideas. Also any tips on how to get rid of the "clank"?

Thanks!

Adam B 05-24-2013 03:45 AM

Re: Tama Speed Cobra problem?
 
Slave lag is an inherent problem with all double pedals. Some are worse than others. Not sure how to reduce it other than lubricant and adjustment. But I don't know for sure. I haven't used a double pedal in a couple years. The lag is one of the reasons I gave up on them.

That being said, my single Speed Cobra has been great for the past two years aside from some squeaking.

Matteo 05-24-2013 04:33 AM

Re: Tama Speed Cobra problem?
 
Yeah, I've been really happy with them so far but I have an old Pearl Export double bass kit that I'm fixing up so I won't have to deal with double pedals anymore. Glad to hear your single speed cobra is working great since that is what I'll be using on my double bass kit.

BrandonXD 05-24-2013 01:57 PM

Re: Tama Speed Cobra problem?
 
That clank you're referring to may be slack in the chains when they bounce back so quickly.
As for the lag; there will always be lag in a double pedal, although there are certain drive shafts which limit the lag greatly

brady 05-24-2013 03:00 PM

Re: Tama Speed Cobra problem?
 
I don't know much about double pedals, but would a direct drive double be faster than a chain drive?

Fuo 05-24-2013 04:33 PM

Re: Tama Speed Cobra problem?
 
1 Attachment(s)
A few months after I got mine, these screws came loose and mine started clanking (just the slave for me). After I tightened them up they've been fine.

drum4fun27302 05-25-2013 11:43 PM

Re: Tama Speed Cobra problem?
 
You have too much angle. The toe board is hitting the return spring down there and the base plate . Bring the pedal up by losening the hex where the spring is. Loosening a lot. Then loosen the other hex by the beater (the one that tightens then big circle /beater around the "disc" adjust your pedal angle that way (higher in your case). Then adjust the 1st one you loosened up to adjust spring tension and voila.
If you made another video and pointed at the different screws and given them numbers , it would make it easier ....

Matteo 05-27-2013 04:45 AM

Re: Tama Speed Cobra problem?
 
Thanks for the tips guys! Will try all of them tomorrow. I'll see about making another video how you described drum4fun if I'm still having problems after making adjustments. Thanks!

drum4fun27302 05-27-2013 02:09 PM

Re: Tama Speed Cobra problem?
 
Ok. I found some instructions online .
http://www.tamadrum.co.jp/world/manu...dCocra_new.pdf

If you look up this link , loosen up screw #4 all the way. Pedal beater should fall on the board as the spring isn't involved anymore. Adjust the pedal height higher by bringing it up with the beater (forget about beater angle you'll get, you can adjust that later. (Mine is about 3.5 inches from the base board at the tip) it shouldn't touch the "cobra coil" underneath. Tighten the screw #4.
Now your beater angle should be all screwed up. Loosen screw #5 on the instructions and set your beater angle (mine is around 5 inches from the bass drum head). Then plsy with the cobra coil and spring tension.
Then do the same on the other pedal .
You can always put more/less angle on the pedal and/or beater and spring tension and see what you like.
Hope this helped.

Matteo 05-30-2013 01:44 AM

Re: Tama Speed Cobra problem?
 
Thanks man! I'm still having trouble with the "deadness" of the left pedal. I've adjusted spring tension and everything and just can't get the left pedal to be as snappy and responsive as the right pedal. Oh well, guess I'll just have to adjust.

drum4fun27302 05-30-2013 02:46 AM

Re: Tama Speed Cobra problem?
 
Try adjusting the cobra spring (the one under the pedal) to give you more rebound.

Sometimes , you feel the left pedal is dead but the problem is thd left foot and not the left pedal. Try playing the left pedal with your right foot and see how it feels.


All times are GMT +2. The time now is 12:30 PM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Bernhard Castiglioni's DRUMMERWORLD.com