Stage custom snare tuning piece stuck?

Vareee

Junior Member
I'm pretty new to drumming in general, and I just bought a used 2014 Stage Custom kit off CL and am trying to get everything set up and working. The guy sold the snare without snares on it and with a broken head, so it's a bit suspicious to begin with.

Anyway, I notice on one side of the snare-attachment parts there is something with a spring and a twisting bolt, above the part which you need a drum key to tighten. Check out the following picture (not my snare), it's the big part right in the center:



The issue is, this part won't turn, which is making fine-tuning the snare difficult (which seems like its purpose). Is it stuck, or is there a way to loosen it up or unlock it or something? I've done a bit of research and can't find much info on it. I can get some real life pictures if it would help out, too.

Thanks guys.
 

Duck Tape

Platinum Member
That's called a snare strainer. It pulls the snares against the bottom head. You operate it by moving the lever up and down.

Is the lever down when you try to adjust the knob? It should help. If the tension adjustment (turny knobby thing) is busted you can work around it by undoing the strainer, then undoing the two tension rods that tighten the plastic strap on the snare wires. Adjust the snare wires by positioning the plastic strap and tighten the screws back up. That might take a few attempts to get it right.

This actually happened to my stage custom snare, it might be worth upgrading the strainer.
 

Vareee

Junior Member
Right, I'm talking about the turny-knob-thing (i.e. Tension adjustment) here. It's supposed to turn, correct? Mine simply won't turn. Do I have to do anything special to get it to turn? There seems to be a hole in the side I could put a mini Allen Wrench in but not 100% sure.

To get around it I think I've been doing what you described: dropping the snares down a bit (via lever) -> pulling pulling the strap through the thing with the drum key screwes -> tightening it -> pulling the snares up. The process seems a bit ugly though and my snares aren't sounding too great.
 

opentune

Platinum Member
It can only turn when the lever is down. If it can't turn with lever down then its possible it is seized right up, OR it is turned so far down into the hole it cannot be moved further. Turn the opposite way. If still not, take it apart.
 

Defender

Silver Member
The stuck knob may be caused by a couple things...

1) The strainer knob might be cranked either all the way down or all the up and is perhaps seized up a bit. (maybe due to some corrosion or maybe because someone cranked the hell out of it up or down).

2) The strainer assembly might be bent in such a way that it feels like it's seized up (in which case it probably is seized up)

3) The strainer assembly might be broke!

FYI... Whenever I buy a used drum (especially a snare drum) I take it home, tear every single piece of hardware off the shell. Give it some TLC with some cleaner on the shell and on the metal pieces. Then I put it all back together again, slap some new heads on it and some new snare wires and BAM!! They sing like they were made too.

In your case, you will want to carefully exam the strainer for any defects. Don't put it back on the drum until you've either fixed it or bought a new strainer. There's no sense in being in a hurry. Do it right! If that means a few more dollars to replace it, then so be it.. Lesson learned.

Good Luck, Defender
 

KamaK

Platinum Member
Pretty much the same advice as above.

The tension adjustment knob is a threaded bolt that extends into the strainer chassis. They tend to get stuck if over-tightened. A couple things you can do, as long as you are 100% prepared to buy a new strainer.

1: Remove the strainer from the snare. Compress the spring and make sure there isn't lock-tight, solder, or debris where the two pieces meet.
2: Pop it in a vice and attempt to unscrew it using pliers or a channel lock. Do not use enough force to shear the bolt.
3: If it won't budge, get a can of compressed air, turn it upside down, freeze where the bolt meets the chassis, try again. Tap the top of the knob lightly with a hammer. Try again. It's either going to come out, or it's going to shear.

Once it's free, take off the spring and evaluate the threads. It's entirely possible that the knob/bolt is not original and is a different thread size than the chassis, and some doofus cranked it in. If it matches, and you've cleaned and cleared all debris (WD40, place the douche blaster deep into the receptacle to blow out the crap while holding it upside down), lubricate the bolt and receptacle with mechanical grease, MolyD, or 3-in-1 and reassemble.
 
Top